Phone Problem

Major incident Support Telephone
2020-02-16 13:44 +0330 · 3 hours, 13 minutes, 36 seconds

Updates

Resolved

The Issue has been resolved

February 16, 2020 · 16:58 +0330
Issue

Call quality issue

February 16, 2020 · 13:45 +0330

← Back