Mobinnet Network issue

Major incident Mobinnet IaaS
49 minutes

Updates

Resolved

Mobinnet network problem resolved

February 16, 2020 · 10:49 +0330
Issue

Mobinnet Network issue

February 16, 2020 · 10:14 +0330