Asiatech Network Issue

Major incident IaaS Asiatech
2020-01-22 13:54 +0330 · 5 minutes, 16 seconds

Updates

Resolved

The issue has been resolved

January 22, 2020 · 13:59 +0330
Issue

Bandwidth drop on Asiatech region, provider issue

January 22, 2020 · 13:59 +0330

← Back