VoIP phone calls issue

Major incident Telephone Support
2020-12-17 00:30 +0330 · 1 hour, 8 minutes, 11 seconds

Updates

Resolved

This incident has been resolved.

December 17, 2020 · 01:38 +0330
Investigating

We are currently affected by an issue regarding our Asiatech phone line (3rd party VoIP Service)

December 17, 2020 · 01:17 +0330

← Back