VoIP phone calls issue

Minor incident Telephone Support
2020-12-15 10:55 +0330 · 7 hours, 5 minutes

Updates

Resolved

This incident has been resolved.

December 17, 2020 · 01:18 +0330
Investigating

We are contacting to Asiatech’s technical team to resolve this issue.

December 15, 2020 · 18:32 +0330
Issue

We are currently affected by an issue regarding our Asiatech phone line (3rd party VoIP Service)

December 15, 2020 · 13:44 +0330

← Back