Voip Issue

Major incident Telephone Support
2020-12-13 10:44 +0330 · 7 hours, 17 minutes, 19 seconds

Updates

Resolved

This incident has been resolved.

December 13, 2020 · 18:01 +0330
Issue

We are currently affected by an issue regarding our Asiatech trunk line (3rd party VoIP Service)

December 13, 2020 · 15:57 +0330

← Back