Ticketing Issue

Major incident Ticketing Support
2020-12-07 09:58 +0330 · 1 hour, 40 minutes, 55 seconds

Updates

Resolved

This incident has been resolved.

December 7, 2020 · 11:38 +0330
Investigating

Our engineers are investigating the issue affecting ticket registration

December 7, 2020 · 10:14 +0330

← Back