Billing

Major incident Services Billing
2020-11-27 11:17 +0330 · 6 hours, 50 minutes, 31 seconds

Updates

Resolved

This incident has been resolved.

November 27, 2020 · 18:07 +0330
Investigating

Our engineers are currently investigating an issue impacting Financial transactions

November 27, 2020 · 11:41 +0330

← Back