Billing

Major incident Services Billing
2020-11-26 23:00 +0330 · 6 hours, 7 minutes, 21 seconds

Updates

Resolved

This incident has been resolved.

November 27, 2020 · 05:07 +0330
Investigating

Our Engineering team is investigating an issue with the billing system.

November 27, 2020 · 03:45 +0330

← Back