Mobinnet Network Issue

Major incident IaaS Mobinnet
29 minutes, 57 seconds

Updates

Resolved

This incident has been resolved.

October 5, 2020 · 01:44 +0330
Issue

Mobinnet Network Issue

October 5, 2020 · 01:41 +0330

← Back