Sales Department Voip Issue

Minor incident Support Telephone
2020-09-15 10:00 +0330 · 2 hours, 50 minutes, 12 seconds

Updates

Resolved

Solved

September 15, 2020 · 12:50 +0330
Issue

Sales Department Voip Issue

September 15, 2020 · 11:06 +0330

← Back