Voip Issue

Minor incident Support Telephone
46 minutes, 36 seconds

Updates

Resolved

This incident has been resolved.

August 10, 2020 · 14:54 +0330
Investigating

We are currently investigating an issue impacting Telephone

August 10, 2020 · 14:29 +0330

← Back