VOD issue

Major incident VoD Platform
2020-07-11 10:24 +0330 · 6 hours, 48 minutes, 25 seconds

Updates

Resolved

Infrastructure issue has been resolved

July 11, 2020 · 17:12 +0330
Issue

Infrastructure issue

July 11, 2020 · 11:19 +0330

← Back