Voip Issue

Major incident Support Telephone
3 days, 4 hours, 52 minutes, 8 seconds

Updates

Resolved

the issue has been resolved .

April 14, 2020 · 22:22 +0430
Issue

Voip Issue

April 11, 2020 · 13:44 +0430