Mobinnet Network Issue

Major incident Mobinnet IaaS
2 hours, 41 minutes, 21 seconds

Updates

Resolved

Issue has been resolved

March 20, 2020 · 18:31 +0330
Issue

Mobinnet popsite bandwidth issue

March 20, 2020 · 18:29 +0330